Задание 9 ЕГЭ по информатике: обработка чисел в электронной таблице

Задание 9 ЕГЭ по информатике даёт файл электронной таблицы, в каждой строке которого несколько чисел, и просит посчитать строки, где выполнены два условия: о повторах чисел и об их сумме или среднем. Решается формулами в дополнительных столбцах или короткой программой на Python.

Как решать

В экзаменационном файле тысячи строк по 4–7 чисел. Условия бывают двух видов: о повторах (все числа различны; ровно одно число повторяется дважды) и арифметические (сумма наибольшего и наименьшего больше суммы остальных; среднее неповторяющихся чисел меньше повторяющегося).

Решение в электронной таблице. Пусть числа строки стоят в столбцах A–F.

Шаг 1. Посчитайте повторы: в G1 запишите =СЧЁТЕСЛИ($A1:$F1;A1) и протяните формулу вправо до L и вниз до конца данных. В каждой ячейке окажется, сколько раз соответствующее число встречается в строке. Все числа различны, если в G–L одни единицы; одно число повторяется ровно дважды, если в G–L ровно две двойки и четыре единицы.

Шаг 2. Посчитайте арифметическое условие функциями МАКС, МИН, СУММ, СРЗНАЧ. Сумму неповторяющихся чисел даёт СУММЕСЛИ(G1:L1;1;A1:F1).

Шаг 3. В последний столбец запишите =ЕСЛИ(И(условие1;условие2);1;0) и сложите этот столбец.

Решение на Python: читайте файл построчно, превращайте строку в список чисел и проверяйте условия через count, max, min и sum. Экзаменационную таблицу для этого сохраняют в формате CSV. Файлы примеров ниже — текстовые, числа в них разделены табуляцией, их открывает и редактор таблиц.

Примеры с решением

Пример 1

В файле 09_ex1.txt в каждой строке записаны шесть натуральных чисел. Определите количество строк, для которых выполнены оба условия:

В ответе запишите только число.

Файл данных: 09_ex1.txt — 40 строк, 694 байта. Первые строки файла:

27	85	28	84	28	31
87	53	66	63	31	60
9	9	86	79	9	50
9	1	81	78	47	81
15	6	28	28	6	6
19	79	79	17	18	2
51	3	35	74	38	35
33	65	55	4	63	76

Проверка ответа на Python

count = 0
with open("09_ex1.txt", encoding="utf-8") as f:
    for line in f:
        row = list(map(int, line.split()))
        repeated = [v for v in set(row) if row.count(v) == 2]
        single = [v for v in row if row.count(v) == 1]
        # одно число встречается ровно два раза, остальные четыре — по одному
        if len(repeated) == 1 and len(single) == 4:
            if sum(single) / 4 < repeated[0]:
                count += 1
print(count)

Ответ: 8

Условиям удовлетворяют строки 4, 6, 12, 21, 24, 33, 36 и 38. Например, в строке 4 (9, 1, 81, 78, 47, 81) дважды встречается 81, а среднее остальных чисел (9 + 1 + 78 + 47) / 4 = 33,75 меньше 81.

В строке 1 (27, 85, 28, 84, 28, 31) повторяется 28, но среднее остальных (27 + 85 + 84 + 31) / 4 = 56,75 больше 28. В строке 3 число 9 встречается три раза, первое условие не выполнено.

Пример 2

В файле 09_ex2.txt в каждой строке записаны четыре натуральных числа. Определите количество строк, для которых выполнены оба условия:

В ответе запишите только число.

Файл данных: 09_ex2.txt — 40 строк, 471 байт. Первые строки файла:

42	40	2	54
44	26	29	25
14	40	27	23
57	14	34	56
46	16	36	42
30	52	12	25
35	55	42	8
53	178	9	42

Проверка ответа на Python

count = 0
with open("09_ex2.txt", encoding="utf-8") as f:
    for line in f:
        row = list(map(int, line.split()))
        biggest = max(row)
        evens = sum(1 for v in row if v % 2 == 0)
        if biggest < sum(row) - biggest and evens == 2:
            count += 1
print(count)

Ответ: 12

Подходят строки 2, 3, 7, 11, 13, 14, 15, 16, 18, 27, 31 и 35. Например, строка 2 (44, 26, 29, 25): наибольшее 44 меньше 26 + 29 + 25 = 80, чётных чисел два.

Строка 1 (42, 40, 2, 54) не подходит: все четыре числа чётные. Строка 4 (57, 14, 34, 56) тоже: чётных чисел три. В таблице первое условие проверяет формула =МАКС(A1:D1)<СУММ(A1:D1)-МАКС(A1:D1), второе — сумма остатков ОСТАТ(A1;2) по строке, равная 2: нечётных чисел тогда тоже два.

Типичные ошибки

Потренироваться на тренажёре

Частые вопросы

Можно ли решать задание 9 ЕГЭ по информатике на Python?

Да. На экзаменационном компьютере есть среды программирования; таблицу сохраняют в формате CSV и читают построчно. Условия с повторами на Python проверяются короче, чем формулами.

Что делает функция СЧЁТЕСЛИ в задании 9?

Считает, сколько раз число встречается в диапазоне строки. По этим значениям видно, все ли числа различны и сколько раз повторяется каждое.

Сколько времени занимает задание 9?

По спецификации 2027 года — около 6 минут, это самое долгое из заданий 1–11. Оценивается 1 первичным баллом.

Официальные материалы

Другие задания

Все задания и структура экзамена — на странице ЕГЭ по информатике. Соседние разборы: задание 8 и задание 10.

Описание задания сверено 28 сентября 2026 года со спецификацией 2027 года (документы 2027 года). Примеры составлены нами по структуре демоверсии, каждое решение запущено, и напечатанный им ответ совпадает с ответом на странице. Кодолимп не связан с разработчиками экзамена. Заметили неточность — напишите нам.