Задание 12 ОГЭ по информатике: сколько файлов с расширением в каталогах

Задание 12 ОГЭ по информатике выполняется на компьютере: нужно посчитать, сколько файлов с заданными расширениями лежит в указанных каталогах, или найти их суммарный объём. Решают поиском по маске в файловом менеджере, например *.jpg, и смотрят число найденных файлов.

Как решать

Шаг 1. Включите показ расширений. В проводнике Windows 11: «Вид» → «Показать» → «Расширения имён файлов». Без этого файл «маршрут.jpg.txt» выглядит как картинка.

Шаг 2. Откройте первый каталог из условия и введите в строку поиска маску, например *.jpg. Проводник ищет и во всех вложенных подкаталогах. Число найденных элементов видно в строке состояния внизу окна.

Шаг 3. Повторите для каждого расширения и каждого каталога и сложите результаты. Чтобы не ошибиться, записывайте числа в таблицу: каталог × расширение.

Шаг 4. Если спрашивают объём, выделите найденные файлы (Ctrl+A в окне результатов), откройте «Свойства» и посмотрите размер. Переведите в те единицы, которые просят в условии.

Ловушки задания: расширение .jpeg не совпадает с .jpg; поиск не различает регистр, поэтому ФОТО.PNG тоже считается; файл «имя.jpg.txt» — текстовый. Внимательно читайте, какие именно каталоги названы: соседние каталоги с похожими именами в ответ не входят.

В примерах ниже вместо настоящих каталогов дан список файлов: путь и размер в Кбайтах через табуляцию. Код на Python считает по списку то же, что вы считали бы в проводнике.

Примеры с решением

Пример 1

Сколько всего файлов с расширениями .jpg и .png содержится в каталогах Поход/Алтай и Поход/Карелия каталога «Задание 12», включая все их подкаталоги? В ответе укажите только число.

Список файлов каталога «Задание 12» с размерами — в файле примера.

Файл данных: 12_ex1.txt — 54 строки, 3,5 КБ. Первые строки файла:

Задание 12/Поход/Алтай/file_1403.jpg	2653
Задание 12/Поход/Алтай/file_3106.mp4	1487
Задание 12/Поход/Алтай/doc_9853.jpeg	2278
Задание 12/Поход/Алтай/doc_1355.docx	2810
Задание 12/Поход/Алтай/doc_1195.png	2101
Задание 12/Поход/Алтай/file_8389.jpeg	1294
Задание 12/Поход/Алтай/doc_5770.jpeg	3272
Задание 12/Поход/Алтай/День 2/file_2787.txt	3847

Проверка ответа на Python

# Задание 12 ОГЭ, пример 1: сколько файлов .jpg и .png в каталогах Алтай и Карелия (с подкаталогами)
count = 0
for line in open("12_ex1.txt", encoding="utf-8"):
    path, size = line.rstrip("\n").split("\t")
    in_folder = path.startswith(("Задание 12/Поход/Алтай/", "Задание 12/Поход/Карелия/"))
    ext = path.rsplit(".", 1)[-1].lower()  # поиск в проводнике не различает регистр букв
    if in_folder and ext in ("jpg", "png"):
        count += 1
print(count)

Ответ: 12

Алтай: 1 файл .jpg и 1 файл .png. Подкаталог Алтай/День 2: 3 файла .jpg и 2 файла .png. Карелия: 5 файлов .png, среди них ОБЛОЖКА.PNG. Итого 2 + 5 + 5 = 12. Файлы .jpeg (их пять) и текстовый «маршрут.jpg.txt» не считаются, каталог Кавказ в условии не назван.

Пример 2

Определите суммарный объём в Кбайтах всех файлов с расширениями .pdf и .odt в каталоге Архив/Документы, включая его подкаталоги. В ответе укажите только число.

Список файлов каталога «Архив» с размерами в Кбайтах — в файле примера.

Файл данных: 12_ex2.txt — 57 строк, 2,9 КБ. Первые строки файла:

Архив/Документы/scan_8334.ods	4385
Архив/Документы/IMG_7538.odt	1408
Архив/Документы/file_8008.odt	776
Архив/Документы/scan_9351.ods	2433
Архив/Документы/photo_1207.odt	1721
Архив/Документы/photo_7654.pdf	1393
Архив/Документы/file_9618.png	2402
Архив/Документы/file_924.ods	1598

Проверка ответа на Python

# Задание 12 ОГЭ, пример 2: суммарный объём (Кбайт) файлов .pdf и .odt в Архив/Документы и подкаталогах
total = 0
for line in open("12_ex2.txt", encoding="utf-8"):
    path, size = line.rstrip("\n").split("\t")
    if path.startswith("Архив/Документы/") and path.lower().endswith((".pdf", ".odt")):
        total += int(size)
print(total)

Ответ: 24672

Подходят 11 файлов: 6 в самом каталоге Документы (9607 Кбайт), 4 в подкаталоге 2025 (14035 Кбайт) и 1 в подкаталоге 2026 (1030 Кбайт). Сумма: 9607 + 14035 + 1030 = 24672 Кбайт. Файлы .docx и .ods в ответ не входят.

Типичные ошибки

Потренироваться на тренажёре

Частые вопросы

Как искать сразу два расширения?

Надёжнее искать по одному и складывать. Числа записывайте на черновик, чтобы не пересчитывать.

Считаются ли файлы во вложенных папках?

Зависит от формулировки. Если сказано «в каталоге и его подкаталогах» или названы подкаталоги, считают всё внутри них. Поиск проводника сам заходит во вложенные папки, поэтому начинать его нужно из того каталога, который назван в условии.

Где взять каталог для тренировки?

В архиве демоверсии 2027 года есть папка с дополнительными файлами к заданию 12. На ней можно повторить подсчёт по маске так же, как на экзамене.

Официальные материалы

Другие задания

Все задания и структура экзамена — на странице ОГЭ по информатике. Соседние разборы: задание 11 и задание 13.

Описание задания сверено 28 сентября 2026 года со спецификацией 2027 года (документы 2027 года). Примеры составлены нами по структуре демоверсии, каждое решение запущено, и напечатанный им ответ совпадает с ответом на странице. Кодолимп не связан с разработчиками экзамена. Заметили неточность — напишите нам.