Задание 1 ЕГЭ по информатике: схема дорог и таблица расстояний

Задание 1 ЕГЭ по информатике проверяет, умеете ли вы читать одни и те же данные в двух видах: на схеме дорог (графе) и в таблице расстояний. Решается на черновике за 2–3 минуты: пункты сопоставляют по числу дорог и по соседям, а длину дороги берут из таблицы.

Как решать

В задании дана схема: пункты обозначены буквами, дороги — линиями. Рядом таблица, где те же пункты обозначены номерами, а в клетке на пересечении двух номеров записана длина дороги между ними. Схему и таблицу составляли независимо, поэтому букве A не обязательно соответствует номер 1.

Шаг 1. Посчитайте степень каждого пункта на схеме — сколько дорог из него выходит. В таблице степень пункта равна количеству заполненных клеток в его строке.

Шаг 2. Найдите пункты с редкой степенью. Если на схеме четыре дороги выходят только из одного пункта и в таблице только в одной строке четыре числа, это один и тот же пункт.

Шаг 3. Остальные пункты определяйте через соседей уже найденных. Например, из двух пунктов степени 2 с найденным пунктом соединён только один, и его номер определяется однозначно.

Шаг 4. Когда оба конца нужной дороги сопоставлены, возьмите число из таблицы на пересечении их номеров.

Иногда граф симметричен, и часть пунктов различить нельзя. Тогда ответ всё равно бывает однозначным: в вопросе спрашивают сумму длин двух дорог, которые переходят друг в друга при симметрии. Такой случай разобран во втором примере.

Программа на экзамене здесь не нужна. Код в примерах перебирает все способы сопоставить буквы и номера, оставляет подходящие и проверяет, что ответ у всех подходящих сопоставлений один и тот же.

Примеры с решением

Пример 1

На схеме дорогами соединены пункты A, B, C, D, E, F, G:

В таблице указана протяжённость дорог в километрах, пункты в ней обозначены номерами от 1 до 7:

       1   2   3   4   5   6   7
   1      11  17              12
   2  11           6      19   8
   3  17              14       9
   4       6              15
   5          14          21
   6      19      15  21
   7  12   8   9

Схему и таблицу составляли независимо, номера в таблице не связаны с буквами на схеме. Определите протяжённость дороги из пункта E в пункт G. В ответе запишите целое число.

Проверка ответа на Python

from itertools import permutations

# Схема: какие пункты соединены дорогами (пункты обозначены буквами)
roads = ["AB", "AE", "BC", "BD", "CD", "CF", "DF", "EF", "EG", "FG"]
# Таблица: протяжённость дорог в километрах (пункты обозначены номерами)
table = {
    (1, 2): 11, (1, 3): 17, (1, 7): 12, (2, 4): 6, (2, 6): 19,
    (2, 7): 8, (3, 5): 14, (3, 7): 9, (4, 6): 15, (5, 6): 21,
}

lengths = {frozenset(pair): km for pair, km in table.items()}
letters = sorted(set("".join(roads)))
answers = set()
# Перебираем все способы сопоставить буквам номера и оставляем те,
# при которых дороги на схеме совпадают с дорогами в таблице
for numbers in permutations(range(1, len(letters) + 1)):
    num = dict(zip(letters, numbers))
    if {frozenset((num[a], num[b])) for a, b in roads} == set(lengths):
        answers.add(lengths[frozenset((num["E"], num["G"]))])

assert len(answers) == 1  # ответ не зависит от выбора подходящего сопоставления
print(answers.pop())

Ответ: 15

Степени пунктов на схеме: A — 2, B — 3, C — 3, D — 3, E — 3, F — 4, G — 2. В таблице четыре числа стоят только в строке 2, значит F — это номер 2.

Пунктов степени 2 два: A и G. С пунктом F соединён только G. В таблице строки с двумя числами — 4 и 5, и с номером 2 связана только строка 4, поэтому G — номер 4.

Второй сосед G на схеме — E. В строке 4 кроме номера 2 заполнена клетка с номером 6, значит E — номер 6. На пересечении строки 4 и столбца 6 стоит 15.

Пример 2

На схеме дорогами соединены пункты A, B, C, D, E, F, G:

В таблице указана протяжённость дорог в километрах, пункты в ней обозначены номерами от 1 до 7:

       1   2   3   4   5   6   7
   1          18  13       7
   2          12       5
   3  18  12                   9
   4  13                  10
   5       5                  16
   6   7          10          22
   7           9      16  22

Номера в таблице не связаны с буквами на схеме. Определите сумму протяжённостей дорог из пункта B в пункт D и из пункта C в пункт E. В ответе запишите целое число.

Проверка ответа на Python

from itertools import permutations

# Схема: какие пункты соединены дорогами (пункты обозначены буквами)
roads = ["AB", "AC", "BC", "BD", "CE", "DE", "DF", "EG", "FG"]
# Таблица: протяжённость дорог в километрах (пункты обозначены номерами)
table = {
    (1, 3): 18, (1, 4): 13, (1, 6): 7, (2, 3): 12, (2, 5): 5,
    (3, 7): 9, (4, 6): 10, (5, 7): 16, (6, 7): 22,
}

lengths = {frozenset(pair): km for pair, km in table.items()}
letters = sorted(set("".join(roads)))
answers = set()
for numbers in permutations(range(1, len(letters) + 1)):
    num = dict(zip(letters, numbers))
    if {frozenset((num[a], num[b])) for a, b in roads} == set(lengths):
        bd = lengths[frozenset((num["B"], num["D"]))]
        ce = lengths[frozenset((num["C"], num["E"]))]
        answers.add(bd + ce)

assert len(answers) == 1  # подходящих сопоставлений два, а сумма у них одна
print(answers.pop())

Ответ: 40

Степени на схеме: A, F и G — по 2, остальные — по 3. Пункты F и G соединены друг с другом, A с ними не связан. В таблице строки с двумя числами — 2, 4 и 5; номера 2 и 5 соединены, значит A — номер 4.

Соседи A — B и C, в таблице это номера 1 и 6. Какой из них B, а какой C, определить нельзя: схема симметрична, если поменять местами B и C, D и E, F и G.

Если B = 1, то D = 3 (второй сосед номера 1), C = 6 и E = 7. Если B = 6, то D = 7, C = 1, E = 3. В обоих случаях в сумму входят одни и те же дороги 1–3 и 6–7: 18 + 22 = 40. Длину одной дороги B–D определить было бы нельзя, сумма же определяется однозначно.

Типичные ошибки

Потренироваться на тренажёре

Частые вопросы

Нужна ли программа для задания 1 ЕГЭ по информатике?

Нет. По спецификации 2027 года задание 1 выполняется без специального программного обеспечения, на него отводится около 3 минут. Код на этой странице нужен только для проверки ответа.

Сколько баллов дают за задание 1?

1 первичный балл. Это задание базового уровня сложности.

Что делать, если пункты на схеме неразличимы?

Проверьте, одинаков ли ответ при всех допустимых сопоставлениях. Если в вопросе сумма длин дорог, которые меняются местами при симметрии схемы, ответ один, хотя отдельные номера определить нельзя.

Официальные материалы

Другие задания

Все задания и структура экзамена — на странице ЕГЭ по информатике. Соседние разборы: задание 2.

Описание задания сверено 28 сентября 2026 года со спецификацией 2027 года (документы 2027 года). Примеры составлены нами по структуре демоверсии, каждое решение запущено, и напечатанный им ответ совпадает с ответом на странице. Кодолимп не связан с разработчиками экзамена. Заметили неточность — напишите нам.